MODX is compatible with PHP 5.0.0 and higher. Please upgrade your PHP installation!